" />

スポンサーリンク

CakePHP 4 PHP

CakePHP4のチュートリアルでno matches found: cakephp/app:4.*

投稿日:

CakePHPをちょっと勉強してみようと思い、
https://book.cakephp.org/4/ja/quickstart.html
に沿ってコマンドを実行していくとエラーが出ました。

$ php composer.phar create-project --prefer-dist cakephp/app:4.* cms
zsh: no matches found: cakephp/app:4.*

CakePHPのバージョンを指定することで、実行できました。

$ php composer.phar create-project --prefer-dist cakephp/app:4.1 cms
Creating a "cakephp/app:4.1" project at "./cms"
Installing cakephp/app (4.1.0)
  - Downloading cakephp/app (4.1.0)
  - Installing cakephp/app (4.1.0): Extracting archive
Created project in /Users/noricgeographic/Documents/myapp/cms
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - cakephp/cakephp[4.1.0, ..., 4.2.8] require ext-intl * -> it is missing from your system. Install or enable PHP's intl extension.
    - Root composer.json requires cakephp/cakephp ~4.1 -> satisfiable by cakephp/cakephp[4.1.0, ..., 4.2.8].

スポンサーリンク

-CakePHP 4, PHP

Copyright© ノリックジオグラフィック for Webエンジニア , 2022 All Rights Reserved Powered by AFFINGER5.